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Abstract:Libraries are subject to stock verification periodically; usually every year to know the status of the 

library collection. There are a number of manual and automatic methods are in practice to verify the stock. Due 

to the revolutions happening in the field of Information and Communication Technology, the bar-coded system 

has become more popular due to convenience and accuracy. The authors have made an attempt to select two 

freely available e-tools; LoMag Barcode Scanner andKutools for Excel and explained various steps to use these 

tools for effective library stock verification in an easy and successful way. 
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1. Introduction 
Stock verification is one of the important functions of any enterprise. The term stock verification is also 

known as stock taking, physical verification or checking, stock inspection, inventory taking, etc. Rani 

&Nagaraju(2013) opine that stock verification is largely applicable for ascertaining the position of stores in 

government and commercial organizations. Dhiman (2000) viewed that the term stock verification is the process 

of checking as to what is in stock in relation to what it was. The emphasis is being put more on finding which 

items are missing than on how much the loss is calculated in rupees. 

Mittal(1993) describes that it is a common practice in big business houses and government departments 

to resort to annual stock taking in order to assess the profit and loss. In the context of libraries, verification of 

stock is different from the verification of stores in private or Government business organizations, so far as the 

purpose of the job and the difference in the meaning of 'Store' and 'Stock' are concerned. The concept of stock 

verification might have its origin when books were scare and were to be strictly guarded for their safety. 

Librarian was supposed to be more a custodian of the stock than a facilitator in providing access to users to their 

desired information.  

As perGFR(2017), the Rule 215, physical verification of Library books explained, complete physical 

verification of books should be done every year in case of libraries having not more than twenty thousand 

volumes. For libraries having more than twenty thousand volumes and up to fifty thousand volumes, such 

verification should be done at least once in three years. Sample physical verification at intervals of not more 

than three years should be done in case of libraries having more than fifty thousand volumes. In case such 

verification reveals unusual or unreasonable shortages, complete verification shall be done 

(https://doe.gov.in/sites/default/files/GFR2017_0.pdf).Chaurasia&Chaurasia (2011) said that the collection in 

the libraries contains various types of information sources.  

The library is a public institution and collections are subjected to accounting and checking, verification 

and reporting. Therefore, stock verification is one of the main components of library management, balance the 

library services and is a process of physical counting and checking inventory in the unit. It is a systematic 

checking of the library holdings with an aim to find out the missing volumes in the library stock and physical 

check-up of the documents on record. It helps to disclose the possibility of fraud, theft or loss or deterioration 

and it reveals the weakness of the system if any. It also helps to take precautionary measures to minimize the 

theft and to replace those missing documents and take appropriate precautionary measures to minimize the theft. 

Besides this, the identification of damaged documents for repairing or binding, rearranging, cleaning and 

withdrawal of obsolete documents are also performed simultaneously. 

Libraries adopt various methods to carry out the stock verification. Sridhar (1991) said that the most 

common methods are- cross verification with accession register, manual verification with orderly numerical 

listing subject-wise verification with sample technique, which uses shelf-list or register. All these not only make 

it cumbersome but also lead to waste of time and efforts. Nowadays the advancement of technology helped the 



Application of E-tools for Library Stock Verification: A Practical Approach 

DOI: 10.35629/7722-1106014349  www.ijhssi.org          44 | Page 

librarians to perform their jobs efficiently and to the ultimate satisfaction of their users and it has revolutionized 

the work culture of modern day libraries. Vasishta & Dhanda (2010) said that the growth of variety of 

computer/mobile based technologies is playing an important role in the efficient working of libraries. Barcode 

technology is one such technology being implemented in the libraries for its faster transactions. Barcodes are 

also widely used in the libraries for stock verification and circulation of documents. The authors have made an 

attempt to apply e-tools; the ‘LoMag barcode scanner for excel’ and ‘Kutool for Excel’ for stock verification 

which can be applied in a systematic way with accuracy. 

 

2. Review of Literature 
There are studies conducted on library stock verification; both on the manual and computerised 

methods. 

Sridhar (1991) explained the stock verification as one of the occupational hazards and a post mortem, 

emphasizes need for clarity of objectives and procedures regarding stockverification and responsibilities of loss, 

points out that the cost of stock verification often farexceed the benefits, highlights norms and procedures of 

stock verification for Government ofIndia institutions, discusses some advantages and various methods and 

procedures of physicalverification, put forth precautionary measures to be taken against loss and mutilation 

oflibrary documents, analyses the issue of responsibility of loss and ways of resolving theconflict of 

responsibility, presents the procedure for write-off of reasonable losses. 

According to Mittal (1984) stock verification implies check of the articles on record. It is a common 

practice in big business houses and government departments to resort to annual stock taking in order to assess 

the profit and loss. 

Kumbar(2000) examined the method of stock verification for assessing the loss of books in17 college 

libraries in Shivamogga city of Karnataka. The questionnaire method was used toobtain necessary data for the 

study. He suggested several measures which include certainpercentage to be written off, availability of 

reprography facilities and vigilance by librarystaff besides other norms by UGC. Few literatures were published 

on the stock verification using computer applications. 

Chandhok (1998) demonstrated the bar-coded system for stock verification and inventory management 

and location control of the stock at IGNOU Library, New Delhi. 

Asundi (2015) in his book- ‘paradigms of stock verification in libraries’, after an elaborate review of 

literature on stock verification, delineates the methods from traditional register to the barcode and use of RFID 

technology. It implies that stock verification is one of the essential functions of maintenance of library materials. 

Suresh &Thanuskodi (2018) describes that mobile technology is reliable and easy to use. It improves 

accuracy and accelerates the processing time, eliminates the typing errors, decreases the costs and improves the 

services. During the stock verification period, routine library activities can be carried out without any 

disturbance. Data-capturing is handy and portable, and there is no problem of scanning the data multiple times. 

 

3. Objectives of the study 
The objectives of the study are; 

 to identify various stock verification methods, 

 to find out various procedures of stock verification, 

 to apply new technologies which would speed up the work and  

 to study the effectiveness of the use of LoMag Barcode and Kutools for Excel in library stock 

verification. 

 

4. Methodology 
The authors have selected freely available LoMag barcode scanner and Kutools for Excel tools and used for 

library stock verification and observed the accuracy in the results. Based on the successful application of these 

tools the present article is prepared and the step by step methods are explained.  

 

5. Methods of Stock Verification 
Sudharani& Nagaraj (2013) states that libraries are traditionally perform the periodic stock verification by 

adopting any one of the methods; 

 By using accession register 

 By using separate register with accession numbers in consecutive order 

 By using slips containing accession numbers 

 By numerical counting of documents on the shelves 

 By using shelf-register cards or shelf-list cards 

 By sample stock verification and 

 By using computers and library management software and other automated methods. 
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In general, Chaurasia&Chaurasia (2011) explains following three types of environments for stock verification of 

documents in the Library; 

 Manual library environments: Only staff involved to verify the stock without the help of computers. 

 Semi-automated: Partial use of computers for stock verifications.  The accession numbers are to be 

keyed into the computers using Microsoft excel. 

 Fully automated: All the library operations will be done using computers i.e.Library Management 

Software, Barcode Technology, Mobile Technology, etc.  

 

6. Computerized Stock Verification in Libraries 
Computerized stock verification is widely used in all types of businesses and departmental shops. The 

success of this has impacted on the functioning of the library and information centers. The barcode is employed 

in libraries to automate the data capture process, circulation system and document stock verification. Barcode 

technology is dependable and simple to use, which increases accuracy and reduces processing time, eliminates 

common errors, lowers costs and enhances services. Simultaneously, everyday operations must be carried out 

without interruption.Usually, integrated library management systems have integrated the bar code systems in 

their software for the purpose of circulation; charging and discharging of documents. They are also be used in 

the stock verification and to a great extent they have facilitated the methods of stock verification. 

Any computerized stock verification requires the following procedures; 

 Create Barcode labels and paste in the books, 

 Barcode reader to capture the data, 

 Create excel spread sheet, 

 Data capturing, modification, 

 Data processing, 

 Data analysis, 

 Reporting. 

 

7. Library stock verification tools 
The authors have selected two e-tools; LoMagBardcode Scanner to Excel and Kutools for Excel for library 

stock verification.  The steps followed are mentioned as follows. 

 

7.1LoMagBarcode Scanner to Excel 

LoMag Barcode Scanner to Excel is a free Business app developed by Longint-IT Company. It enables 

to save different data to Excel files. By using this appthe smart phone / tab works as data collector without any 

limitations to the amount of collected codes. Here data sets will be saved in Microsoft Excel format compatible 

with version 97 and newer.The output file may be quickly sent via e-mail or saved to SD card / Onedrive / 

Dropbox / Google drive or other cloud storage. There is also a possibility of continuing the scanning in the 

selected data set. To perform the scan, device needs to be equipped with a camera with autofocus 

function(LoMag-Barcode-Scanner-2).  

 

The barcode reader supports the following code formats: 

 codes on products: EAN-13, EAN-8, ISBN, UPC-A, UPC-E  

 industrial codes: Codabar, Code 128, Code 93, Code 39, ITF, RSS 

 2D codes: QR Code, Data Matrix(longint.com) 

LoMag Barcode Scanner to Excel 1.41 apkrequires the following permissions on android device 

 write to external storage 

 access the camera device 

 access to the vibrator 

 open network sockets 

 access information about networks 

 flashlight 

 access precise location (apkmonk.com). 

 

i)Steps to Install  

LoMag barcode scanner can be downloaded from Google Play platform and it works on a smart phone or a tab 

with android version 2.1 or newer and a camera.  

In the following stage, the information window will appear, allowing us to have access to information that the 

application need to run properly. Then, as shown in Figure-1, authorise it to access the appropriate modules by 

clicking "Accept" before beginning to download the app. 
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Figure 1: Installation of LoMag barcode scanner to Excel 

 

ii) Operation of the App’ 

To launch the LoMag barcode scanner; click it to run the app on android phone.When the app is launched, the 

main navigation menu will be displayed comprising of several modules as shown in figure 2. 

 

 
Figure 2: Launching of LoMag barcode scanner to Excel 

 

iii)Choosing a scanning method 

We can scan barcodes in a variety of ways with the LoMag barcode scanner app. But we can select only and 

exclusively the barcode as shown in Figure 3. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3: Setup of LoMag barcode scanner to Excel 

 

A window will appear with a request to confirm the creation of a new file (we can change the file 

name). To proceed, click ‘Confirm’. The scanner will now run and scan the barcode with the smart phone's or 

tablet's video camera, scanning, recognising, and saving the barcode as seen below.  A sound signal and written 

information at the bottom of the screen will alert us that the code has been scanned. The scanner resets the 

display after scanning the code, and it is ready to scan another code in 4-5 seconds. After scanning of each 

barcode has been saved as accession number in a excel sheet as shown in figure 4. 
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Books of each rack should be scanned in a separate excel sheet. (E.g.: Rack-1,    Rack-2, Rack-3 etc.) It 

helps to find out and rectify if the double entry issues without any difficulties. Then each file should be sent by 

mail from smart phone and saved in a personal computer.  

 

 
Figure 4: Document scanning using LoMag application 

 

7.2 Kutools for Microsoft Excel 

Kutools for Excel is a downloadable suite designed to simplify, automate and expand the features and 

functions of Microsoft Excel.  It is a handy Excel add-in with more than 300 advanced features to simplify 

various kinds of complicated tasks into a few clicks in Excel. For example, Excel users can easily combine 

worksheets with several clicks, merge cells without losing data, paste to only visible cells, and so on. 

Undoubtedly, this powerful and user-friendly add-in will save Excel users a mass of working time and greatly 

improve working efficiency. Trial version of this add in with full features is available for 60 days 

(extendoffice.com). Download the installer and double click that to install Kutools for excel. Make sure that the 

Excel is not open when installing Kutools. After the installation of Kutools for excel add-in, open an excel sheet 

and the add-in appears on the menu bar. Then consider any of the options required from the following menu 

 Go to the Home tab of the Ribbon 

 Open the Conditional Formatting drop-down menu 

 Select ‘Highlight Cell Rules’ 

 Then select ‘Duplicate Values… 

 That will open the Duplicate Values Window 

 Choose the formatting you want to apply and click OK 

 

 
Figure 5: Kutools for Excel add-in 

 

There is a preset rule for highlighting duplicate cells in all Excel versions. Following steps are to use this rule in 

worksheets. 

 Choose a column, a row or a group of cells to work with

 Select Conditional Formatting > Highlight Cells Rules > Duplicate Values... from the Home tab 

 By default, the Light Red Fill and Dark Red Text formats are chosen in the Duplicate Values dialogue 

window. Then click OK 
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 Paste the accession numbers rack wise as shown in figure 6. If any accession number repeats (double 

entry) both the cells will be highlighted with a bright color to attract our attention.   

 

Figure 6: Highlighting duplicate entries 

 

The next step is to transform the data from multiple columns to single column.  “Select the columns 

data which we use, and go to Kutools>Range > Transform Range. Check the Range to single column option in 

the Transform Range dialog, and then click Ok. Select a cell to insert results as shown in figure 7 (ex: M1), then 

click OK. The columns have now been combined into a single column. (https://www.extendoffice.com) 

 

 
Figure 7: Transform the data from multiple cells to single column 

 

Then select and cut that single column and paste it in column A in sheet 2. Here click on home tab> 

sort to filter>sort smallest (A) to largest (Z) and select ‘continue with the current selection’. Now the accession 

numbers display in a descending order. Then  

 Select the sequence in column A and click Kutools > Insert > Find Missing Sequence Number.  

 In the Find Missing Sequence Number dialog, check Inserting blank rows when encountering 

missing sequence numbers option.  

 Then click ok, and a dialog pops out and shows how many missing numbers were found, and then 

click ok to close it. 

Now the blank rows are inserted when encountering missing numbers in the selected sequence numbers as 

shown in figure-8. 

 

 
Figure 8: Tracing out the missing gaps 

 

In the next step the accession numbers of total collection in the library to be put in column B, then in 

column C1 type the formula of =B1-A1 press enter and again place the cursor on C1 and drag it to entire column 

till the last number. Then place the Cursor again on C1 >Data>Filter. Click on Down Arrow on C1> Number 

https://www.extendoffice.com)/
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Filters> Does Not Equal. In the option custom AutoFilter select ‘0’ and click OK. Now the missing numbers are 

displayed as shown in figure-9 

 

 
Figure 9: List of missing numbers 

 

8. Conclusion 
The stock verification helps to know the present status of the holdings of the library.  Stock verification 

using modern technologies is important which improve the efficiency and accuracy of the system.  It helps to 

find out the anomalies in the library management accurately. The present paper explained the step by step 

methods of use of 'LoMag Barcode Scanner to Excel’ and ‘Kutools for Excel' applications for library stock 

verifications. The use of the applications proved that the stock verification is systematic and fault free andthe 

reports generated by the system is accurate without human interaction. 
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